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Workshop 3:  Introduction to Spatial Analyst 
 
This exercise introduces the Spatial Analyst extension for ArcGIS 
9.1.  Within the ArcGIS suite of programs, Spatial Analyst serves as 
the primary modeling and analytical tool for raster or grid-based 
data.  Spatial Analyst encompasses a wide range of analytical and 
geoprocessing tools, including tools for surface analysis, 
interpolation, reclassification, grid mathematics, zonal and focal 
functions, and distance and density computations.  While most of 
Spatial Analyst’s tools perform some sort of cell-based analysis, 
many of tools carry out data conversions or pre-processing.  For 
instance, before executing a statistical routine, users often wish to 
reclassify values, convert from vector to raster format, or modify the 
cell size.  All of these tasks can be accomplished with Spatial 
Analyst.  
  
 
In this workshop, we will learn about the capabilities of Spatial 
Analyst in the context of a typical GIS project.  Suppose we want to 
identify suitable areas for a re-vegetation project near Hilo.  These 
areas must meet specific criteria for slope, aspect, rainfall, solar 
radiation, and land use.  Starting with a variety of data (including an 
elevation grid, rainfall samples points, a solar radiation grid, and 
land use polygons), we will create a new grid for each of the five 
criteria.  Then we will combine these grids into one raster that shows 
the areas that meet all five criteria.  
 
Before starting, create a new folder for your work on the (Z:) drive 
entitled “gis_workshop3”.  The full path should be: 
 
Z:\gis_workshop3 
 
Now start ArcMap 9.1 with a new empty map.  Before going any 
further, you will need to enable the [Spatial Analyst] extension.  To 
do so, click on the [Tools] menu and select [Extensions].  Tick the 
box next to [Spatial Analyst] and close the window.   
 
Next you will need to display the [Spatial Analyst] toolbar by going 
to the [View] menu, choosing [Toolbars], and then selecting 
[Spatial Analyst].  The [Spatial Analyst] toolbar, which can be 
docked anywhere, should appear as below: 
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Step 2: Copy Input Data          
 
 
 
 
 
 
 
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 3: Add DEM_10  
 
 
 
 
 
 
DEM_10 Attribute Table. 

 
 

From the standard toolbar, click on the ArcCatalog icon  to 
launch ArcCatalog, or alternatively, open ArcCatalog from the 
[Start] button. 
  
The data for this workshop lies in the folder: 
 
I:\ITER_GIS_Workshops_Fall2005\Workshop3\Data   
 
First, let us copy all the files from the above (I:) drive location to our 
new folder on the (Z:) drive.  Remember to copy the files using 
ArcCatalog to ensure that all the necessary files are transferred.  
Please refer to Workshop 1 if you have forgotten how to copy files in 
ArcCatalog.  After copying the files, our new (Z:) drive folder 
should contain the following:  
 

     
 
 
We can now work exclusively from our (Z:) drive folder.  With the 
[Preview] tab selected, click on each of the input files one at a time 
to get an brief overview of the data.  
 
 
Switch to your ArcMap window, click on the [Add Data] button 

, and add the raster data set DEM_10 (a digital elevation model 
with cell size = 10) to your ArcMap document.  Right-click on the 
layer name, and open the [Layer Properties] menu.  Under the 
[Source] tab, you will see a variety of information.   Some of the 
most useful entries include the number of rows and columns, cell 
size, extent, projected coordinate system, datum, and map units.   
 
Next right-click on the layer DEM_10 in the Table of Contents and 
select [Open Attribute Table].  Note that attribute tables for rasters 
contain 3 fields: object id, value, and count.  Essentially raster tables 
function as histograms, with the value column displaying a list cell 
values and the count column displaying the frequency of each value.  
For floating point rasters with greater than 512 unique values,  
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Step 4: Setting the 
Environment 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 5: Surface Analysis 
 
 
HS_10 raster. 

 

 ArcGIS will not build an attribute table, nor will you be able to view 
it.  In this case, the [Open Attribute Table] option will appear in 
dim letters.      
 
Click on the Toolbox icon  to open the Toolbox.  Right-click on 
the empty space anywhere in the Toolbox window and select 
[Environments].  In the [Environmental Settings] dialog box, we 
can set various options that apply to any tool we execute.  For 
instance, under the [General Settings] tab, which we can expand by 
clicking the adjacent arrows, we can set the following parameters: 
 
Current workspace (input folder): Z:\gis_workshop3 
Scratch workspace (output folder): Z:\gis_workshop3 
Output coordinate system:  Same as layer DEM_10 
 
Under the heading [Raster Analysis Settings], set the cell size to 
“Same as layer DEM_10”, or 10 meters on a side.  Note that these 
settings apply to all tools run from the Toolbox, but not to those run 
from the toolbar.  Click [OK] to save these settings.  For tools run 
from the [Spatial Analyst] toolbar, you must define the analysis 
environment from the toolbar’s pull-down menu by choosing 
[Options] at the bottom of the list.  Most of the toolbar settings are 
comparable to those in the Toolbox.  Later in this exercise, we will 
modify the analysis environment for the toolbar.   
 
For both ArcToolbox and the toolbar, setting the environment helps 
to minimize the required inputs when running specific tools.  For 
example, once your default cell size and coordinate system are 
defined, you will not need to define these parameters each time you 
run a tool, unless you want to override the default settings.       
 
In this step, we will create raster data sets for slope and aspect, as 
well as hillshade, which we will use for display.  In the Toolbox, 
expand Spatial Analysis Tools > Surface Tools.  Let us create the 
hillshade grid first.  Double-click on the [Hillshade] tool.  For the 
required parameters (i.e., the ones with green dots next to them), 
choose DEM_10 as the input and type in Z:\gis_workshop3\HS_10 
as the output raster.  Leave the remaining parameters at their default 
settings, and click [OK].  When ArcGIS completes this task, close 
the run window.  ArcGIS automatically adds the new hillshade to 
your map.  Using the default parameters for sun azimuth and 
altitude, ArcGIS assigns an integer from 0 to 255 to each cell, based 
on the amount of sunlight hitting each cell.  The more light exposure, 
the higher the hillshade value.  Note that the relatively flat areas on 
the map receive much more light than the steep stream channels.  
Hillshade maps have a 3D look to them, although they are actually  
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Slope_10 raster. 

 
 
 
 
 
Aspect_10 raster. 

 
 
 
 
 
Step 6: Interpolation 

two-dimensional.  They make excellent background layers on which 
to overlay partially transparent layers.   
 
Next double-click on the [Slope] tool, choosing DEM_10 as the 
input and Z:\gis_workshop3\Slope_10 as the output raster.  Leave 
the output measurement in degrees, and click [OK].  After closing 
the run window, ArcGIS displays the new slope raster.  When 
calculating slope, ArcGIS computes the maximum change in 
elevation from each cell to its neighbors.  Like the hillshade raster, 
the slope grid illustrates a sharp contrast between the steep stream 
channels (shown in red) and the gently sloping areas in between 
(shown in green).  The coastline also exhibits a steep bluff, while the 
ocean area is flat.  Later in this exercise, we will learn how to 
exclude the ocean from our area of analysis. 
 
Lastly, double-click on the [Aspect] tool in the Toolbox, selecting  
DEM_10 as the input and Z:\gis_workshop3\Aspect_10 as the 
output raster.  Click [OK], and close the run window when 
completed.  The [Aspect] Tool computes the steepest downslope 
direction for each cell, based on the elevations of neighboring cells.  
The output cells contain direction measured in degrees, starting at 0 
degrees for north-facing cells and moving clockwise back to 360 
degrees.  Flat cells are given a designation of –1.   
 
In general, the Aspect_10 raster exhibits an easterly aspect, with 
stream channels areas showing both northern and southern aspects 
depending on where the cell lies relative to the stream.  The offshore 
cells appear flat as we would expect.  
 
If you have not done so already, be sure to save your map document!       
 
 
One of the most common ways to create a raster surface is to 
interpolate from point data.  Based on the assumption that 
geographic values are spatially autocorrelated (i.e., that near points 
are more alike than distant ones), the process of interpolation applies 
various mathematical techniques to estimate unknown values. In this 
step, we will generate a rainfall grid using point data as our starting 
point.   
 
A few different methods of interpolation are available in Spatial 
Analyst, including Inverse Distance Weighting (IDW), Kriging, 
Natural Neighbor, and Spline techniques.  The first three methods 
are weighted average techniques, while the last one relies on curve- 
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Interpolation tools. 

  

fitting techniques.  Each method has advantages and disadvantages, 
depending upon the particular data distributions and trends.   
 
A detailed comparison of the interpolation methods is beyond the 
scope of this exercise, but I will offer a couple observations about 
how ArcGIS treats these methods.  IDW is the only method that 
allows users to define barriers, effectively by dividing the area of 
interpolation into independent regions.  Kriging, which uses spatial 
autocorrelations and sophisticated math to generate weights, works 
best on normally distributed data.  If you want to apply kriging in 
more advanced ways, the ArcGIS extension Geostatistical Analyst 
offers additional features.  Spline techniques, which rely on curve-
fitting techniques, capture high and low points, instead of averaging 
out the extremes.  While spline techniques can estimate values 
outside the range of input values, they perform poorly on densely 
distributed points with extreme gradients. 
   
In your map document, add the three data sets: Rainfall_Pt.shp, 
Study_Area.lyr, and Land_Area.lyr.  Make sure the rainfall points 
are at the top of the Table of Contents.  Click of the full extent icon 

 to view all of the rainfall sample points.  You may want to 
change the color of the rainfall points to make them more visible.   
 
Now we are ready to interpolate a surface from these points.  Open 
the attribute table for Rainfall_Pt.shp, and observe that the last 
column entitled “Rain_inch” contains annual rainfall values in 
inches.  In the ArcToolbox > Spatial Analyst Tools > 
Interpolation folder, open the [IDW] tool.  Enter the following 
parameters, and press [OK]. 
 
Input Point Features:  Rainfall_Pt 
Z value field:   Rain_inch 
Output raster:   Z:\gis_workshop3\IDW_Rain 
Search Radius:  Variable 
Number of Points:  6 
 
After the tool runs, close the run window and look at the new layer.  
Let us symbolize this layer differently.  Open the [Layer 
Properties] menu for IDW_Rain, and select the [Symbology] tab.  
In the window in the upper right, make sure the “Classified” option 
is highlighted.  Select “8” for the number of classes and press the 
“Classify” button.  In the Classify dialog box, select “Manual” as the 
method and enter the following break values: 120, 140, 160, 180, 
200, 220, 240, and 260.  Press [OK] twice.  Your interpolation 
surface IDW_rain should appear as follows:   
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To save our symbols, right-click on the layer IDW_Rain, choose 
[Save as layer file], navigate to your folder, and name your layer 
IDW_Rain.lyr.  Once you save these symbols in a layer file, you 
may import them and use them to represent other layers.  We will try 
this in a moment.   
 
Let us interpolate another rainfall surface, this time using the method 
of kriging.  From the Interpolation set of tools, open the [Kriging] 
tool and choose the following parameters:       
 
Input Point Features:  Rainfall_Pt 
Z value field:   Rain_inch 
Output raster:   Z:\gis_workshop3\Kriging_Rain 
Search Radius:  Variable 
Number of Points:  6 
 
After this interpolation finishes, open the [Layer Properties] 
window for Kriging_Rain, and click on the [Symbology] tab.  
Instead of manually setting the symbols, we can import the symbols 
from the layer IDW_Rain.lyr by pressing the [Import] button and 
browsing to the layer we just saved IDW_Rain.lyr.  Now our two 
interpolation surfaces have the same categories and color symbols, 
making them visually comparable.  
 
To visually evaluate surfaces, it is often useful to display and label 
the input points over the surfaces.  Open the [Labels] tab under the 
[Layer Properties] menu for Rainfall_Pt.shp.  Tick the box next to 
“Label features in this layer”, and choose “Rain_inch” as the label 
field.  Now we can see the labeled input points on top of the output 
surfaces.  If you want to view the kriging and IDW surfaces 
simultaneously side-by-side, you can put them in different data 
frames and view them in layout mode.  Otherwise, you can tick and  
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Step 7: Extraction  
 
 
 

untick the box next to the kriging surface to view them separately.  
The two surfaces exhibit similar patterns, although they are distinctly 
different.  Evaluating which surface fits our data better is a 
complicated and lengthy process that is beyond the scope of this 
exercise.  It is important to note that fitting surfaces typically 
requires multiple iterations and a systematic analysis of parameters 
and techniques.   
 
                       IDW_Rain.                              Kriging_Rain. 

                 
 
Let us arbitrarily choose to use the kringing surface for the rest of 
our analysis.  At this point, we can remove the layer IDW_rain from 
our map document to simplify the Table of Contents.  
 
 
As you probably noticed, our kriging interpolation surface extends 
well beyond our study area.  In this step, we will look at a couple 
different ways to extract subsets of data.  In a previous workshop, we 
used the Clip tool (ArcToolbox > Analysis Tools > Extract > Clip) 
to extract part of a data set; however, this tool only operates on 
vector data, not grids.  To clip raster data, you may use a raster clip 
tool from the following location: 
 
ArcToolbox > Data Management Tools > Raster > Clip  
 
Another way to clip raster data is to use the Extraction tools found 
under the Spatial Analyst tool set: 
 
ArcToolbox > Spatial Analyst Tools > Extraction  
 
Within Spatial Analyst’s tool set, probably the easiest way to limit 
the extent of our kriging surface is to use the [ ] 
tool.  This tool applies the concept of masks, which can be either 
feature or raster layers in ArcGIS.  A mask layer serves as a layer 
that delimits which cells to include (and exclude) in a particular 
analysis.  If a cell in the mask layer has valid data, then ArcGIS will  
 
 

Created by Paul Berkowitz, UHH EPSCoR-ITER  ..\workshop3.doc 
Last modified 11/2/2005 
 

7



Introduction to Spatial Analyst 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
     Solar_clip raster. 

 
 
 
Step7: Vector to Raster 
 
 
 

process that cell; otherwise if the cell has “NoData” in it, then 
ArcGIS will not process that cell.   
 
Double-click on the [ ] tool, enter Kriging_Rain as 
the input raster, Study_Area as the input mask, and 
Z:\gis_workshop3\Rain_Clip as the output.  
 

 
 
After this tool runs, open the [Layer Properties] window for 
Rain_Clip, press the [Symbology] tab, highlight “Classified”, and 
import the layer file IDW_Rain.lyr to assign the same categories 
and symbols as the other interpolation surfaces.  We now can 
remove the layer Kriging_Rain from our map document, and untick 
the box next to Rainfall_pt.shp. 
 
Let us practice what we just learned on another grid.  Add the layer 
file Solar_Grid.lyr to your map document.  Using the 
[ ] tool again, extract the cells from Solar_Grid.lyr 
that fall within the Land_Area.lyr and give the output raster the 
name Solar_Clip.  Now symbolize the clipped data set by importing 
the symbols from the file Solar_Grid.lyr.  You can remove 
Solar_Grid from your map now.  Once completed, your clipped 
raster should resemble the one on the left.  Your map may look 
slightly different, depending on what layers are visible behind the 
Solar_Clip raster.  
 
 
Our last piece of input data is a shapefile containing land use 
polygons.  Add the layer file Landuse.lyr to your map document.  
Before using this data set, we must convert it to raster format.  We 
can do this from the Spatial Analyst toolbar menu.  
 
Pull down the toolbar menu and select [Options].  Under the 
[General] tab, set the working directory to Z:\gis_workshop3 and 
coordinate system to be the same as the active data frame.  Under the 
[Cell Size] tab, set the analysis cell size to “Same as the layer 
DEM_10”, or 10 meters.  Click [OK].   
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Step 8: Reclassification 
 
 
  Old 
Values 

 New 
Values 

      New 
      Label 

11-17   1 Urban 
21-24   2 Agriculture 
  42   3 Forest 
 
 
 
 
 
 

Next, pull down the Spatial Analyst toolbar again, and select 
[Convert] > [Features to Raster].  Choose Landuse as the input 
feature, “LANDCOVER” as the field, 10 as the cell size, and 
Z:\gis_workshop3\Landuse_Grid as the output raster.  Click [OK]. 
 

 
 
Move the output raster Landuse_Grid above Landuse.lyr in the 
Table of Contents.  (Beware of quirk: If ArcGIS misnames the grid 
“Landuse_Grid-Landuse_Grid”, then click on the name in the 
Table of Contents and type in “Landuse_Grid”).  Open the [Layer 
Properties] menu for Landuse_Grid and press the [Symbology] 
tab.  Notice that this raster is symbolized with 8 unique values. 
 
Instead of our 8 unique land use codes, suppose we want to 
reclassify our data values into three categories: (1) urban, (2) 
agriculture, and (3) forest.  To convert from the original grid to a 
new grid, use the mapping table on the left. 
 
Under Spatial Analyst Tools > Reclass, open the [ ] 
tool.  Set the input raster to Landuse_Grid, the reclass field to 
“Value”, the output raster to Landuse_Zones, and type in the 
mapping table below.  To make the table appear as below, you may 
need to press the button entitled [Unique].  Press [OK]. 
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Landuse_Zones raster. 

 

 
 
Step9: Raster Math 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
9A. Mean Slope 
 
 
 

Once ArcGIS adds the new grid, you can symbolize and label the 
three new categories appropriately.  Your grid should resemble the 
one to the left, depending on your symbol selections.  You can 
remove Landuse_Grid from your map now. 
 
Remember to save your map document if you have done so recently. 
 
 
 
 
 
 
In the previous steps, we generated, interpolated, extracted, 
converted and reclassified raster surfaces.  Now we are ready to use 
some of Spatial Analyst’s mathematical operations on these grids.  
Using five of the raster surfaces (Slope_10, Aspect_10, Rain_Clip, 
Solar_Clip, and Landuse_Zones) from our map document, we will 
use Spatial Analyst to find cells that meet the following criteria: 
 

(1) Mean slope < 25 degrees. 
(2) Aspect between 135 and 225 degrees (south-facing). 
(3) Rainfall < 180 inches per year. 
(4) Solar radiation >= 350 Calories/cm2 per day.  
(5) Land use not equal to 1 (urban). 

 
Those cells that meet all the above criteria will be considered 
suitable for our re-vegetation project.  As a first step, we will treat 
each of these criteria individually, creating a binary (0/1) raster for 
each one.  Binary rasters store values of either 0 or 1 in each cell.  In 
our case, we will store a value of 1 in cells that meet the specified 
criteria, and a value of 0 in cells that do not. After creating these 
rasters, we can combine them into a one grid that stores overall 
suitability.   
 
Before we make any further calculations, let us define the data set 
Land_Area as our mask to restrict our analysis to cells on land.  We 
can do this from the [Environmental Settings] menu.   Under the 
section [Raster Analysis Settings], select Land_Area as the mask, 
and click [OK].  Now all Toolbox computations will be limited to 
the land area polygon.    
 
Using the grid Slope_10, let us compute a new grid Slope_Mean 
that contains slope values averaged over a 30-meter radius.  The 
average slope grid will smooth out localized irregularities in the 
topography.  This step gives us an opportunity to familiarize 
ourselves with neighborhood functions and statistics. 
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To compute mean slope, open Spatial Analyst Tools > 
Neighborhood > Focal Statistics.  Complete the dialog box as 
follows, selecting a circular neighborhood with a radius of 3 cells: 
 

 
 
 
 
Note that you can work in either cell units (number of cells) or map 
units (meters).  You also can choose the shape of the neighborhood 
and the type of statistic you wish to calculate.  Click [OK] and close 
the run window when complete.  ArcGIS adds Slope_Mean to your 
map.  Do not worry about the symbols in this layer since it is an 
intermediate step. 
 
To create a binary grid that delineates slopes less than 25 degrees, 
open the tool:  
 
Spatial Analyst Tools > Math > Logical > Less Than      
 
In the dialog box, choose Slope_Mean as the input raster, “25” as 
constant value 2, and name the output raster Slope_LT25.   
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Slope_LT25 raster. 

 
 

 
 
 
   
9B. Aspect 
 
 
 
Aspect_South raster. 

 
 

 
 

 
 
The [Less Than] tool creates a binary raster, where cells with a 
slope less than 25 degrees have a value of 1.  Looking at the 
resulting raster, you can see that most cells, except for the stream 
ravines and coastal bluffs, have a slope less than 25 degrees.  For 
now, leave the symbols at their randomly selected values.   
 
To create a binary grid for southern aspects, we can use the [Con] 
tool from the following location:  
 
Spatial Analyst Tools > Conditional > Con. 
 
This tool operates as a traditional if-then-else statement.  You will 
need to enter the input raster Aspect_10, the output value (1) for 
cells that meet the condition, the output value (0) for cells that do not 
meet the condition, the output raster name Aspect_South, and the 
conditional expression.  In our case, the condition is for cell values 
to fall within the range 135 to 225 degrees (see below).       
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9C. Rainfall 
 
Rain_LT180 raster. 

 
 

 
 
 
9D. Solar Radiation 
 
 
Solar_GE350 raster. 

 
 

 
 
 
9E. Land Use. 
 
 
 

From the resulting raster, you can see that many of the cells meeting 
this condition lie on the north side of stream gulches. 
 
To create a binary grid for rainfall, we can use the [Less Than] tool 
as we did in Step 9A, except this time choose Rain_Clip as the input 
raster, “180” as constant value 2, and Rain_LT180 as the output.  
The resulting grid delimits the lower elevations with less than 180 
inches of annual rain.   
 

 
 
 
This step is similar to the last, except this time we will use the 
[Greater Than Equal] tool from the same tool set.  Enter the 
parameters below, naming the output Solar_GE350, and click [OK]. 
 

 
 
Like the rainfall pattern, the lower elevation cells meet the condition 
while the higher and cloudier areas do not.   
 
Finally, to compute the binary raster for land use, we can use the 
tool: 
 
Spatial Analyst Tools > Math > Logical > Not Equal. 
 
Enter the parameters below and click [OK]. 
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Not_Urban raster. 

 
 

 
 
 
Step 10: Map Algebra 
 
 
   ArcToolbox. 
 

  
 
 
 
Spatial Analyst Toolbar. 
 

 
 
 

 
 
The output raster Not_Urban separates cells into urban (1) and non-
urban (0) areas. 
 
One of the most powerful aspects of Spatial Analyst is its map 
algebra language.  This language allows you to manipulate and 
process grids, much the same way that regular algebra allows you to 
manipulate variables and numbers.  Map algebra processing 
includes: basic operations such as addition, subtraction, and 
multiplication; arithmetic functions such as absolute value and 
truncation of decimal places; trigonometric functions such as sine 
and inverse tangent; logarithms, square roots, and powers; 
conditional expressions; neighborhood functions and statistics; and 
geographic functions such as slope and hillshade. 
 
Throughout this exercise, we have used various tools from 
ArcToolbox and the toolbar to process our grids.  Instead of using 
these tools, we could have performed virtually all of these tasks 
using Spatial Analyst’s map algebra language.   
 
How can we access this language?  ArcGIS provides four ways to 
access map algebra: two ways from the Toolbox, one from the 
Spatial Analyst toolbar, and another from the ArcInfo command 
prompt.  We will ignore the last method because it is mostly useful 
for programmers who want to automate lengthy routines.  
 
In ArcToolbox, under Spatial Analyst Tools > Map Algebra, you 
will find two map algebra tools.  As the names imply, one allows for 
multiple statements and outputs, while the other allows for single 
expressions and outputs.  Until you become comfortable with the 
syntax of map algebra, it makes sense to use the [Single Output 
Map Algebra] tool, executing one statement at a time.  This makes 
it easier to find and correct syntax errors.              
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Open the [Single Output Map Algebra] tool, and then press the 
[Usage] button to view the list of operations and functions.  Notice 
that the list includes hillshade, slope, aspect, kriging, greater than, 
reclass, etc.  Just for fun, let us look at how map algebra syntax 
works.  
 
Suppose we want to use the mean sea-level temperature (23.3°C) 
and elevation (DEM_10) to make a rough estimate of the average 
temperature in each cell, based on environmental lapse rates.  In the 
[Single Output Map Algebra] tool, we can set the output raster to 
Temp_Celsius and type in the right side of the following equation in 
the expression window: 
 
Temp_Celsius = 23.3 - (2.7 * DEM_10 / 1000) 
 

 
 
This tool executes the above algebraic equation on a cell-by-cell 
basis, assigning temperatures to each cell, and producing a new grid 
that shows how temperature declines with elevation.  Untick the box 
next to the grid Temp_Celsius to make it invisible.   
 
Now let us use the toolbar’s [Raster Calculator] to finish our 
project.  We will use our five binary grids (Slope_LT25, 
Aspect_South, Rain_LT180, Solar_GE350, and Not_Urban) to 
identify cells that meet all five criteria.  Since our binary grids 
delimit suitable areas with a value of 1 and unsuitable areas with a 
zero, we can sum these grids on a cell-by-cell basis to get an overall 
measure of suitability.  In the summed grid, those cells that sum to 
five meet all five criteria. 
 
From the Spatial Analyst toolbar, open the [Raster Calculator], and 
press the expand button  to view additional functions.  In the 
expression window, enter the equation below (either manually or 
using buttons) and press [Evaluate]:     
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Suitability raster. 

 
 

 
 
 
Suitability raster. 

 
 
 
 
 
    
      

Suitability = [Slope_LT25] + [Aspect_South] + [Rain_LT180] + 
[Solar_GE350] + [Not_Urban] 
 

 
 
This expression creates a new raster called Suitability, with values 
ranging from 1 to 5.  You can view the exact distribution of these 
values in the attribute table.  The map on the upper left shows this 
raster, symbolized from light to dark, with the darkest areas 
representing the most suitable cells. 
 
Another way to view this result is to overlay Suitability on top of 
the hillshade raster HS_10.  Untick the boxes next to every layer 
except Suitability and HS_10.   If you want, you can use the 
[Extract by Mask] tool, along with the Land_Area layer, to create 
a subset of the hillshade layer that excludes the ocean. 
 
Since we are interested primarily in cells with a value of 5, we can 
make the other categories invisible.  For Suitability, open the 
[Layer Properties] menu, and symbolize values of 5 in “leaf green” 
and other values as “hollow” or “no color”.  Under the [Display] tab 
for Suitability, set the transparency to 40% to allow the hillshade 
layer to show through partially.  The map should appear similar to 
the adjacent map. 
 
We also can use ArcScene to view our results in 3D.  Enable the 3D 
Analyst extension and open ArcScene.  Add Suitability, HS_10 (or 
your extracted hillshade layer if you created one), and DEM_10 to a 
new ArcScene document.  In the [Layer Properties] menus for 
Suitability and HS_10, set the source of base heights to DEM_10. 
In the Table of Contents, untick the box next to DEM_10 to make it 
invisible.  Now symbolize the grids appropriately, as we did in 
ArcMap.  For the hillshade layer, under the [Rendering] tab, set the  
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draw priority to 2 to ensure that the hillshade layer appears behind 
Suitability.  You may want to add the Study_Area shapefile to your 
document, and symbolize it in blue to represent the ocean.  The map 
below shows a close-up perspective of these layers in ArcScene. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Congratulations!  You are now ready to apply Spatial Analyst to 
your own research. 
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