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Getting Started 

Workshop 2:  Introduction to 3D Analyst 
 
This exercise introduces the extension 3D Analyst for ArcGIS 9.1, 
and explores different ways to represent 3-dimensional surfaces, 
including TINs (Triangulated Irregular Network) and rasters (grids). 
 
Most maps that we use are two-dimensional, whether they appear on 
a piece of paper or on a computer screen.  For instance, if we go 
hiking in a wilderness area, we typically bring along a contour map 
that lies in a two-dimensional plane.  While useful for visualizing the 
topography, two-dimensional maps have limitations.  The 3D 
Analyst extension of ArcGIS 9.1 allows users to leap beyond the 
traditional 2D mapping environment and into the world of 3D 
visualization.  In 3D Analyst, users can view surfaces, interact with 
data, and perform complex analysis. 
 
In terms of data, the difference between 2D and 3D is that three-
dimensional data has z-values while 2D data has only x and y values.  
For instance, longitude and latitude might represent x and y, while 
altitude represents the z-value.  3D Analyst can be used with either 
(1) feature data (i.e., discrete points, lines, or polygons such as 
plants, trails, or buildings), or (2) continuous data such as rainfall, 
temperature, or evaporation.   A couple of examples:  the discrete 
boundaries of a parcel of land on the Hamakua coast can be viewed 
3-dimensionally along the slope of Mauna Kea, or continuous 
rainfall data can be represented as a 3D surface over an area. 
 
In this exercise, we will learn how to use ArcMap and ArcScene to 
create, represent and visualize 3D data.  Working from a 2D digital 
contour map (elevation isolines), we will create TIN and raster 
surfaces.  Then we will drape high-resolution images over these 
surfaces to create 3D representations of the landscape, perform fly-
throughs, and produce animation files.  Based on our work, we will 
produce one ArcMap layout showing various representations of the 
same area, and one ArcScene document useful for producing fly-
throughs and animation files.   
 
In our next workshop, we will discuss how to create surfaces from 
point features instead of lines, using the interpolation methods of 
Spatial Analyst and 3D Analyst.      
 
Before starting this exercise, create a new folder for your work on 
the (Z:) drive entitled “gis_workshop2”.  The full path should be: 
 
Z:\gis_workshop2 
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Step 1: Assembling Data 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next, start ArcMap 9.1 with a new empty map.  Before going any 
further, you will need to enable the extension [3D Analyst].  To do 
so, click on the [Tools] menu and select [Extensions].  Tick the box 
next to [3D Analyst] and close the window.  Next you will need to 
display the toolbar for [3D Analyst] by going to the [View] menu, 
choosing [Toolbars], and then selecting [3D Analyst].  The [3D 
Analyst] toolbar should appear as below. 
 
 

                                                                         
 
You can dock the toolbar anywhere within the ArcMap window.  
From the standard toolbar, click on the ArcCatalog icon  to 
launch ArcCatalog, or alternatively, open ArcCatalog from the 
[Start] button. 
   
Most of the data for this workshop comes from DBEDT’s website 
and is in the folder: 
 
I:\GIS_Workshops\Workshop2\Data   
 
 
First, let us copy the 7 shapefiles from the above (I:) drive location 
to our new folder on the (Z:) drive.  Remember to copy the files 
using ArcCatalog to ensure that all the necessary files are 
transferred.  Please refer to Workshop 1 if you have forgotten how to 
copy files in ArcCatalog.  After copying the files, our new (Z:) drive 
folder should contain the following shapefiles:  
 

 
 
Switch to your ArcMap window, click on the [Add Data] button 

, and  add coast_arc_Hilo_Clip.shp and 
hawcntrs100_Hilo_Clip.shp to your ArcMap document.  For each 
shapefile, open the [Layer Properties] menu and click on the 
[Source] tab.  Notice that both files have the same projected 
coordinate system:  NAD_1983_UTM_Zone_4N.  Now click on the   
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 [Fields] tab for each file.  Note that both shapefiles contain a field 
named “CONTOUR” that contains elevation data.  Unfortunately, 
the contour data set does not include a zero-foot contour line.  Thus, 
in order to create a more accurate elevation surface over the whole 
land area, we will want to use data from both the coast and contour 
shapefiles.  
 
At this point we have a choice in how to proceed: (a) combine the 
coast and contour data into one data set and create a TIN from that 
data set, or (b) create the TIN directly from the two separate 
shapefiles.  Let us choose the former option to give us some practice 
with personal geodatabases. 
 
In your ArcCatalog window, right click on your folder 
“gis_workshop2” and select [New] > [Personal Geodatabase].   
 
    

 
  
ArcCatalog will create a new Access database for us.  Single click on 
the default title “New Personal Geodatabase” and rename it to 
“Elevation”.  Now right-click on “Elevation” and select [New] > 
[Feature Class].   
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Name the new feature class “CONTOUR100” and press [Next]. 
Press [Next] again in the second [New Feature Class] dialog box.   
 

 
 
In the third dialog box, we need to define three things:  
 
(1) Single click on the “SHAPE” field in the top box, and set the 

Geometry type to “Line”.  
 
(2) Click on the  button in the lower right corner, across from the 

Spatial Reference field.  When the [Spatial Reference 
Properties] box appears, press the [Import] button, and browse 
to the shapefile: hawcntrs100_Hilo_Clip.shp.  Click [Add] and 
then [OK].  Your Spatial Reference will now be set to 
NAD_1983_UTM_Zone_4N.   

 

Geometry   Type 

e
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Import Spatial 
Reference 

 
(3) Lastly, create a new field called “CONTOUR” by typing 
“CONTOUR on line 3 of the “Field Name” column.  Set the “Data 
Type” to “Double” and “Precision” to “11”.  Now click [Finish] to 
return to the main ArcCatalog menu. 
 
 

 

Data TypeNew Field 

Precision
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Step 2: Creating a TIN 
 

 

Now that the feature class properties are set, we can load the coast 
and contour data sets into the feature class “CONTOUR100”.  Right-
click on CONTOUR100 and select [Load] > [Load Data].  Click 
[Next] once.  Browse and open coast_arc_Hilo_Clip.shp and press 
[Add].  Press [Next] multiple times to select the default choices and 
then press [Finish].  ArcMap will load the coast shapefile into our 
new feature class, mapping the original values for CONTOUR to the 
new field CONTOUR.  
 

 
 
Repeat the above process, this time loading data from 
hawcntrs100_Hilo_Clip.shp into CONTOUR100.   
 
Returning to ArcMap, add the feature class “CONTOUR100” to 
your map.  Notice that CONTOUR100 contains all the contour lines 
including the coastline.  This feature class will be the input for our 
first TIN.  We can remove all other layers at this point.   
 
Note: If you could not complete Step 1, you can use ArcCatalog to 
copy I:\GIS_Workshops\Workshop2\Data\Elevation.mdb to your 
working folder, and then add CONTOUR100 to your map document.   
 
In ArcGIS we can create a TIN using either the 3D Analyst toolbar 
or ArcToolbox.  ArcToolbox offers more flexibility and control, but 
is not as easy to use.  Let us create a TIN using the 3D Analyst 
toolbar, and then we can modify it using ArcToolbox. 
 
Pull down the 3D Analyst toolbar and select [Create/Modify TIN] > 
[Create TIN From Features].  
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  TIN1 

 
 
 
 
 
 
 
Step 3: Editing a TIN 

In the dialog box, tick the box next to CONTOUR100, set the Height 
Source equal to “CONTOUR”, choose to triangulate as “hard line”, 
and name the output file as Z:\gis_workshop2\TIN1.   
 

 
 
Selecting hard break lines forces ArcMap to draw triangles that do 
not cross break lines.  This option ensures a change in slope at the 
break lines.  Hard lines are useful for modeling ridges, streams, 
roads, and shorelines, while soft lines are better for features such as 
rolling hills.  I arbitrarily chose hard break lines for this example to 
ensure a more accurate representation of the coastline, although the 
other contour lines might be modeled more accurately using soft 
lines. 
 
ArcMap adds TIN1 automatically, using an arbitrary line symbol for 
the hard edges and an equal-interval color ramp for elevation. 
 
Before continuing, please save your ArcMap document in your 
working folder.  Remember to save your work frequently!   
 
ArcMap allows you to edit TINs in a variety of ways.  You can (a) 
insert additional break lines, (b) replace polygons with flat surfaces 
(e.g., to represent lakes or terraces), (c) clip or erase polygons, or (d) 
fill polygons with attribute data.  We will demonstrate two types of 
editing.  First we will create a flat area on our TIN to represent 
Wailoa estuary, and second we will clip out a portion of our TIN to 
match the extent of our satellite imagery. 
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   TIN1 and Estuary.shp 
   (original TIN surface) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
   TIN1 and Estuary.shp 
      (after hardreplace)  

 
 

Let us start by adding the shapefile Z:\GIS_Workshop2\ 
estuary.shp to our document.  Symbolize the estuary in dark blue, 
click next to the symbol in the Table of Contents, and label the 
symbol  “Wailoa”.  Zoom in closely on the estuary.  Notice that 
several triangles intersect the estuary polygon.  Use the identify tool 

 to examine the TIN1 elevations within the estuary polygon.  
You will need to set the layer to TIN1 within the [Identify Results] 
box.  According to our TIN1 surface model, the estuary has an 
elevation range of over 50 feet. 
 

 
 
For the sake of this exercise, let us suppose we want to represent the 
estuary as a flat surface with an elevation of zero.  To edit TIN1, 
click the ArcToolbox icon .  Double click on the tool 
under ArcToolbox > 3D Analyst Tools > TIN Creation. 
 

 
 
Choose TIN1 as the input (using the down arrow), estuary as the 
input feature class, elevation as the height field, and hardreplace as 
the SF (surface feature) type.  Click [OK].   
 

Created by Paul Berkowitz, UHH EPSCoR-ITER  .\\.\SDAL\Applied_Geoinformatics\Hands-On_WorkshopsWorkshop2_Intro_to_3Danalyst_23Sept05.doc 
Last modified 9/27/2005 
 

8



Introduction to 3D Analyst 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                TIN3 

 
 
 
Step 4: Creating a Raster 
 
 
 

Using the identify tool, examine the new estuary elevation.  The 
estuary surface should have a constant elevation of zero. 
 
For our second editing task, let us clip out a rectangular polygon that 
corresponds to the extent of our satellite imagery.  Return to the full 
extent .  Add the image boundary from the shapefile 
Z:\GIS_Workshop2\Image_Frame.shp, and symbolize it with the 
hollow symbol.  Open the tool again, choosing TIN1 as the 
input, Image Frame as the input feature class, <None> as the height, 
and hardclip as the SF type.  Click [OK]. 
 

 
 
After this tool executes, untick the layer CONTOUR100.  Notice 
that TIN1 now has the same boundaries as Image Frame.    
 
 
 
Before we switch to ArcScene, let us create a raster surface (or grid) 
from our TIN.  We can convert any TIN to a grid using the 3D 
Analyst toolbar.  Pull down the 3D Analyst toolbar menu and select 
[Convert] > [TIN to Raster].  In the dialog box, choose TIN1 as the 
Input TIN, “10” as the cell size, and “raster10” as the output raster.  
Click [OK] and ArcMap will compute the raster and add it to your 
map.  This sort of elevation grid is known as a Digital Elevation 
Model (DEM).  To make the coastline more visible, we can add the 
shapefile Z:\GIS_Workshop2\ Water_Area.shp to our map,   
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  ArcMap view of raster10 
 
 
 
 
 
 
 
 
 
 
Step 5: ArcScene 
 
 
 
 

and symbolize it in dark blue. 
 

 
 
 
Up to this point, we have been working with and creating 3D 
surfaces; however, we have been viewing these surfaces in the 2D 
map display area of ArcMap.  Let us open ArcScene and see how 
our data looks in 3D.  From the 3D Analyst toolbar in ArcMap, click 

on the ArcScene icon .  Once the ArcScene window opens, click 

on the [Add data] button , browse to raster10, and press [Add].  
 

 
 
Once again to distinguish the coastline, add the shapefile 
Water_Area.shp and symbolize it in blue.  To make the scene 3D, 
double click on the layer raster10 to display the [Layer Properties]  
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ArcScene view of raster10 
 
 
 
 
 
 
 

 
 
 

menu.  Under the [Base Heights] tab, press the circular button next 
to “Obtain base heights from surface”.  This option instructs ArcMap 
to display raster10 using its z-values.  Note that from this dialog box, 
you can display surfaces with constant values, expressions, scaling 
factors , or offsets. 
 

 
 
Now select the [Rendering] tab and tick the box next to “Shade 
areal features relative to the scene’s light position”.  Press [OK]. 
 

 
 
Like in ArcMap, you can adjust the sun’s position by right-clicking 
on  in the Table of Contents and selecting the 
[Scene Properties] > [Illumination] tab.   
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Step 6: Draping Imagery 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

Within ArcScene, you can negotiate the display area with a wider 
range of tools than in ArcMap.  The adjacent tools allow you to 
navigate, fly, zoom, center, target, and set observers.  Experiment 
with them, especially the navigate tool  which allows you to 
adjust your perspective. 
 
Within ArcScene, we could view our TIN using the same method as 
above.  To save time, we will move on to draping photos over a 
surface.   
 
First we need to add two image files to our ArcScene document.  
Click the [Add Data] button , browse to the folder 
C:\ITER_GIS_Workshops_Fall2005\Fly_Demo\Data, and add the 
images HawaN21.tif and HawaN22.tif.  This may take a while since 
the images are large (154 MB each). 
 

 
 
Notice that ArcMap adds the images in a horizontal plane, as the 
base heights are set to a constant value of zero by default.  Let us 
reassign these values.  For each of the image files, open the [Layer 
Properties] menu, select the [Base Heights] tab, and choose to 
obtain the heights from the surface raster10.  In the Table of 
Contents, untick the boxes next to raster10 and water area, so that 
only the two images are visible.  Now open the [Scene Properties] 
menu, and set the vertical exaggeration to 1.5 and the background 
color to navy blue.  Your scene should resemble the one on the next 
page. 
 
Before we continue, let us export this image as a JPEG file.  Then 
we can paste it into an ArcMap layout at a later time.  Under the 
[File] menu, select [Export Scene] > [2D].  Browse to your working 
folder, name the file Satellite view, and set the file type to JPEG.  
We will use this exported file in Step 8. 
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Step 7: Fly-Throughs  
and Animation 
 
 

 
 
 

 
 

 
 
 

In workshop 1, we learned how to use the Fly tool  to fly over our 
scene.  Refer back to workshop1 to refresh your memory of how this 

tool works.  You may want to use the Navigate Tool  to adjust 
your perspective.  Also, if you want to start flying from the same 
point every time, you can create a bookmark from the [View] menu 
and return to it at any time.   Here is a partial list of other useful 
commands for flying: 
 
Left-Click  Zoom In (fly speed = 0, 1, 2, 3 etc.) 
Right-Click  Zoom Out (fly speed = 0, -1, -2, -3, etc.) 
Up Arrow  Fine Tune Zoom In 
Down Arrow  Fine Tune Zoom Out 
ESC   Freezes Flight 
 
After a bit of practice, you should be ready to record a flight.  We 
can capture a flight in two ways: (1) by recording the flight directly, 
or (2) by building an animation file from key frames.  Let us start 
with the first method.   
 
Before we begin, we need to open the [Animation] toolbar from the 

[View] menu.  Then press the  button on the end of the toolbar to 
view the [Animation Controls] window.  Lastly, press the 
[Options] button to see more animation controls.  
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Step 8: Producing a  
Layout  
 
 
 
 
 
 
 
 
 

Now we are ready to record a flight.  Follow these steps: (a) press 
the record button , (b) conduct a flight, (c) press the [Esc] key to 
freeze the scene, and then (d) press the stop button  to end the 
recording.  You can review your flight using the play button .  
Note that you can reassign the length of the animation, choose a time 
interval to play, and select the mode of play (forward, backward, 
etc.).   
 
The second way to record an animation is using key frames.  Under 
the animation toolbar, select [Clear Animation].  Then press the full 
extent button .  Now we will use the camera button  to capture 
a series of keyframes that ArcScene will link into a video.  As a 
demonstration, let us create a video of our scene rotating 360 
degrees.  Press the camera button  to capture the starting frame.  

Now using the navigate tool  rotate the scene clockwise 
approximately 30 degrees and press the camera button  again.  
Continuing rotating and pressing the camera button periodically until 
you return to the original view, facing approximately east 
downslope.  To view your video, simply press the play button  in 
the [Animation Controls].   
 
We can export our video by selecting the [Export to Video] option 
under the toolbar.  Then others can view it using video software such 
as Real Player, Quick Time, or Windows Media Player.  Note that 
under the animation toolbar menu, the [Animation Manager] option 
allows us to edit our videos. We can save and close our ArcScene 
document now. 
 
For review, let us summarize what we have done in an ArcMap 
layout.  We can create a simple layout depicting the following five 
data frames: (1) the original contours, (2) the TIN symbolized as 
Delaunay triangles, (3) the TIN elevations symbolized with a color 
ramp, (4) the raster surface, and (5) the satellite imagery in 3D.   
 
Returning to your ArcMap document, maximize the ArcMap 
window and close ArcToolbox.  Pull down the [Insert] menu and 
insert three new data frames.  Press the layout button  in the lower 
left corner of the map display area to switch to layout view.  Under 
the [File] menu, select [Page and Print Setup] and change the 
orientation to landscape.  From the [Insert] menu, insert the JPEG 
file from Step 6 (Z:\gis_workshop2\satellite_view.jpg).   
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In the layout view, you will have to click and drag your data frames, 
so that they are not superimposed.  At this point, your layout might 
resemble the one to the left.  All we need to do move layers to the 
empty data frames, symbolize them appropriately, and add some 
cartographic elements. 
 
In the first new data frame (“New Data Fame”), copy the layers 
Image Frame and CONTOUR100, and insert a legend. 
 
In “New Data Frame 2”, copy these three layers: water area, estuary, 
and TIN1.  For TIN1, open the [Layer Properties] menu and click 
on the [Symbology] tab.  Press the [Add] button and choose “Edges 
with the same symbol”.  Press [Add] again and then [Dismiss].  
Untick the boxes for “Edge Types” and “Elevation”, and press [OK].  
With this data frame activated, insert a legend. 
 

 
 
In “New Data Frame 3”, copy the same layers as data frame 2, 
except this time symbolize elevation using a graduated color ramp.  
Untick the box next to ”edge types”.   
 
The final data frame entitled “Layers” (by default) has all our 
original layers in it already.  We simply need to tick the boxes next 
to the layers water_area, estuary, and raster10, placing them in that 
order.  Depending on your cartographic choices, your layout should 
resemble the one on the next page. 
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